home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / net-wireless / kismet-2006.04.1 / kismet-2006.04.1.ebuild < prev    next >
Text File  |  2006-04-19  |  2KB  |  68 lines

  1. # Copyright 1999-2006 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/net-wireless/kismet/kismet-2006.04.1.ebuild,v 1.1 2006/04/14 11:33:38 brix Exp $
  4.  
  5. inherit linux-info
  6.  
  7. MY_P=${P/\./-}
  8. MY_P=${MY_P/./-R}
  9. S=${WORKDIR}/${MY_P}
  10.  
  11. DESCRIPTION="IEEE 802.11 wireless LAN sniffer"
  12. HOMEPAGE="http://www.kismetwireless.net/"
  13. SRC_URI="http://www.kismetwireless.net/code/${MY_P}.tar.gz"
  14.  
  15. LICENSE="GPL-2"
  16. SLOT="0"
  17. KEYWORDS="~amd64 ~ppc ~x86"
  18. IUSE="gps ncurses"
  19.  
  20. RDEPEND="net-wireless/wireless-tools
  21.         ncurses? ( sys-libs/ncurses )
  22.         gps? ( app-misc/gpsdrive
  23.                 >=dev-libs/expat-1.95.4
  24.                 dev-libs/gmp
  25.                 >=media-gfx/imagemagick-6.0
  26.                 dev-perl/libwww-perl )"
  27. DEPEND="${RDEPEND}
  28.         >=sys-devel/autoconf-2.58
  29.         sys-apps/sed"
  30.  
  31. src_unpack() {
  32.     unpack ${A}
  33.  
  34.     sed -i -e "s:^\(logtemplate\)=\(.*\):\1=/tmp/\2:" \
  35.         ${S}/conf/kismet.conf.in
  36. }
  37.  
  38. src_compile() {
  39.     # the configure script only honors '--disable-foo'
  40.     local config=""
  41.  
  42.     if ! use ncurses; then
  43.         config="${config} --disable-curses --disable-panel"
  44.     fi
  45.  
  46.     if ! use gps; then
  47.         config="${config} --disable-gpsmap"
  48.     fi
  49.  
  50.     econf \
  51.         ${config} \
  52.         --with-linuxheaders=${KV_DIR}/include \
  53.         || die "econf failed"
  54.  
  55.     einfo "You may safely ignore the warning about the missing .depend file"
  56.     emake dep || die "emake dep failed"
  57.     emake || die "emake failed"
  58. }
  59.  
  60. src_install () {
  61.     emake DESTDIR=${D} install || die "emake install failed"
  62.  
  63.     dodoc CHANGELOG README TODO docs/*
  64.  
  65.     newinitd ${FILESDIR}/${P}-init.d kismet
  66.     newconfd ${FILESDIR}/${P}-conf.d kismet
  67. }
  68.